Dashing Strike Rubberbanding

  • For the past couple weeks or so, I have been noticing some horrible rubberbanding on my LoN LTK Monk. I speed farm very fast on this build, so this is very noticeable.

    What happens, is when I am spamming Dashing Strike while my Ingeom is procced. I notice that I will either dash to a weird location, or that I will kind of rubberband. It used to be a very smooth animation and I would go in the direction that my mouse was pointing.. Simply not the case anymore.

    Is there anything I might be able to fix that could be causing this issue? I thought that it could possibly be a latency issue, but my latency is consistent with what it has always been. Even though it is higher than I would like it to be, which is between 95-110 ms.
  • We have seen Quality of Service(QoS) packet shaping or packet loss be a major factor in rubberbanding within the game. I would recommend to check the following:

    - Check to ensure you have the latest network adapter drivers installed. You generally can get this from the Motherboard Manufacturer.
    - If you have a KillerNetwork adapter find "Bandwidth Control" and disable it within the KillerNetwork Manager.
    - Check your router for QoS features and disable them. Your Internet Service Provider may be able to assist here if they provided the router or you can contact the router's manufacturer for support here.

    After that if the issue continues, collect a WinMTR if the issue continues so we can check the connection path:

    A WinMTR test shows your connection to our servers over time instead of a snap shot, that a pathping or tracert can offer us. This is great at picking up fluctuating connection issues such as your latency spiking up and down or why disconnects are occurring:

    1. Download WinMTR
    2. Unzip the file to your desktop
    3. Open the WinMTR folder and select the 32 or 64 bit version. Choose whichever one corresponds to your version of Windows. Run the WinMTR.
    4. Type the IP under “host”:
    5. Click “start" and run the test for at least 5 minutes before hitting the "Stop" option.
    6. Click “Copy text to clipboard” and paste the results here. Please also copy and paste a Dxdiag within code blocks. That makes this large amount of information much easier to read!
  • Hey Gimpzor,

    I am sorry there was such a delay in the response back to you.

    It does look like the connection to the servers is getting stopped at the hop that is showing 58% packet loss. This hop is still well outside our network and ISP. When using a VPN your connection is likely routed through a different path over the internet so the connection does not go through this hop. Using a VPN may be the best option at this time.

    You can reach out to your ISP and let them know the connection is getting routed through this bad hop. They would need to work with their peering partners to change how the connection is routed to avoid this hop or get it fixed.

    Before you do contact your ISP power cycle the network equipment and flush the DNS could help.
  • Hey there Gimpzor. Drakuloth here, filling in for Zuvykree.

    I've never seen a situation where rubber banding is related to a character build. That would be very odd. Rubber banding is a situation where your client sends information to the server which never makes it (usually due to packet loss like we saw in your MTR test.) The server periodically asks where your character is from your client. It knows how fast it's possible for a character to move, and to prevent some forms of hacking, the server is considered the ultimate authority for 'where your character is' at any given time. If a few packets are dropped while your character is going from point A to B to C to D, the server thinks "oh, you can only be at point B right now." So, it 'resets' you to that position. On your end, it looks like you snapped back like you were pulled by a rubber band, but it's your last known possible location on the server's end. To the server, you were likely standing still for a few of those packets, and it just 'corrects' your end. This is why we're troubleshooting connection, here.

    It's probable that the situation you've got is sporadic and just started showing back up, or you've got more things going on on screen with the LoN build or something. I know I used a LoN Splintering Shield build on my crusader and it moved way faster / had a ton of things going on while playing it once I got some gear on it. We'll keep an eye out for more reports, but this is the first I've ever heard of something like this. I would recommend continuing to work on that connection issue with your ISP. I'm pretty confident that once that's fixed, your problem will be as well. If not, just get us a new WinMTR and we'll check it out!
  • Gimpzor,

    Latency doesn't affect FPS directly. High latency can have some similar symptoms as low FPS, but if you're ending up with low FPS that's a video issue of some kind, as your graphics card is just pulling information from your harddrive to render. (It doesn't need to ask the servers how to draw things, it just needs to know what's on screen).

    As for Sand Shaper, this isn't the only time I've heard of players getting lower FPS with that style mob or wizard characters. If you go onto a wizard with the spell Energy Twister and spam it near mobs, does it have the same effect?

    In any case - can you try resetting your video driver settings and see if it improves? If not, if you enable the "Low FX" setting in your graphics options, does that fix it? How about turning down the in game anti aliasing or unchecking SSAO?

    As for your connection tests, they can be prone to having spikes of useful information and not so useful information. It all depends on what kind of packet shaping is being done by each ISP. Whenever we see EXCEEDINGLY high packet loss like that, I tend to wonder if it's just the ISP partially blocking the test. It's hard to tell if that high packet loss hop is just packet shaping or not, but with that much packet loss you probably wouldn't be able to connect at all. Unless you were almost constantly having problems for 10 minutes I would discount that.

    Other than that, the channeling pylon 'fixing' the issue is a tad interesting. You'd have less things nearby you, which might cause less information to go through your router. The first thing I'd do if possible is bypass the router (if you have a separate router/modem.) If that works, or if you can't do that, can you try factory resetting your router? You may need to google how to do this for your router make and model, as it's different for each one.
  • Sure thing, please do keep me updated!

    One more thing to keep in mind as you troubleshoot FPS is that we have a new 64 bit client which your machine would have defaulted to (as it's plenty powerful to run it.) There are still a few kinks being worked out with that client to optimize it, so you may also find improvements by running the 32 bit client instead. Once we get some of the issues with the 64 bit client worked out, it should allow you to get more out of your rig than the 32 bit mode, so you can try periodically swapping back.

    There have also been reports of some connection issues being exacerbated by being in a large number of communities. You can try leaving communities for the time being (keep a list of them in case you want to re-join!) and see if that helps any with the rubber banding.
  • Okay, perfect. Thanks for that. It looks like you're not alone with the whole Uliana in 64 bit mode thing. I dug into this some more today, and it looks like as of now the Uliana's Strength FPS Drops in 64 bit mode is actually something we're aware of. The developers are working on it now, and it should be fixed in a future patch!

    It's possible that the Dashing Strike issue is also a bug after all, but if this is the case we wouldn't be able to provide much more help here, unfortunately. If this particular skill is the only one that's suffering from rubberbanding and it's happening on multiple clients with the same gear sets/legendaries in cube, then we're most likely not looking at a connection problem anymore.

    What I'd ask here is that you post about this on the Bug Report forum as well. After the troubleshooting we've exhausted here, this may be something that needs the devs to check it out, and getting some visibility on the bug forum can help as well.

    I'm happy to keep an eye on this thread nonetheless and see if we can come up with anything else we can try.
  • Hey again Gimpzor!

    Thanks for following up on this. It looks like your posts were getting incorrectly spam flagged. Really sorry about that! I've unflagged as spam and hidden some of the duplicates. Hopefully that housekeeping makes the thread make a little more sense. The FPS dips in 64 bit mode with the friends list opened aren't a known issue, so I hopped on my personal D3 client to test. Interestingly, it appears to happen to me on both the 32 and 64 bit clients, for a dip of ~ 40 FPS. I'm still staying above 120 FPS because of my hardware, but it is odd.

    A few questions - may be related. How many battle.net friends do you have? It doesn't seem to be happening to all of us here and we use similar hardware, but I was able to make it happen so we need to find out what's similar between you and I.

    Edit: A couple of the other forum folks and myself played with this some more to see if we could fix it, as it was persisting some on my account no matter what PC I was on. We were able to eliminate any FPS drops on my account by resetting in game options. To do that:

    1. Open the battle.net application, click Options above the news river, and click Game Settings
    2. Click the Reset In-Game Options setting

    Let me know how that goes!

    Regarding the rubberbanding, I'd probably need to see the tests to be sure, but high packet loss could definitely cause the program. Depending on which server(s) you're connecting to, that packet loss may or may not be relevant.

    Easiest way to tell which server you're on is actually to run a different command in Command prompt.

      1. Join a game of Diablo III
      2. Type CMD in your windows search bar, right click Command Prompt, and Run as Administrator
      3. Enter the following command into the prompt:
      netstat -an | find "3724"
      You'll get an output with an IP that looks like this:
      4. Remove the colon and everything after it. The remaining bit (in this example, is the IP you're connected to.
      5. Run your trace to that specific IP.