Flickering

  • My game is flickering wildly
  • Hey, Grimmow!

    If this is similar to other people having this issue, you can try the following steps:

    Disable Fullscreen Optimization:
    • In the Blizzard App, select the Options drop down in the Diablo 3 tab and select Show in Explorer
    • Locate the Diablo III\x64\ folder, then Right-click on Diablo III64.exe and select Properties
    • Go to the Compatibility tab and check the box ‘Disable fullscreen optimizations’
    • Press Apply and OK

    Some other players have stated using Windowed modes and enabling Vertical Sync has also resolved the issue for them.

    We are still investigating the cause of this, as it is affecting many of our games.