Huge lag spikes

  • Hi I'm playing on the Americas from the Isle of Man. I'm connected to a Linksys AE3000 adapter and all of my drivers are up to date. The router is a Fritz Box 3490 with up to date drivers as well.

    I'm having huge lag spikes with my game making it almost unplayable in spots. I tried direct connecting my laptop to the cable modem through a LAN cable and my ping seems to hold steady around 150-200 but I still get spikes.

    I'll post the WinMTR below, hopefully someone can help me analyze this. Thanks for your help!

    |------------------------------------------------------------------------------------------|
    | WinMTR statistics |
    | Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
    |------------------------------------------------|------|------|------|------|------|------|
    | 195.10.125.248 - 1 | 529 | 528 | 5 | 58 | 2755 | 23 |
    | 195.10.125.248 - 1 | 525 | 523 | 5 | 59 | 2756 | 27 |
    | 195.10.125.226 - 1 | 529 | 528 | 5 | 44 | 2683 | 9 |
    | 195.10.107.73 - 1 | 529 | 528 | 14 | 53 | 2686 | 16 |
    | 195.10.107.73 - 1 | 526 | 524 | 14 | 52 | 2684 | 19 |
    | xe-8-3-0.edge3.London15.Level3.net - 0 | 533 | 533 | 13 | 52 | 2681 | 15 |
    | No response from host - 100 | 107 | 0 | 0 | 0 | 0 | 0 |
    | No response from host - 100 | 107 | 0 | 0 | 0 | 0 | 0 |
    | BLIZZARD-EN.ear1.NewYork5.Level3.net - 0 | 533 | 533 | 82 | 118 | 2690 | 89 |
    | 37.244.3.33 - 0 | 533 | 533 | 178 | 211 | 2684 | 180 |
    | No response from host - 100 | 107 | 0 | 0 | 0 | 0 | 0 |
    | No response from host - 100 | 107 | 0 | 0 | 0 | 0 | 0 |
    | 37.244.0.103 - 1 | 525 | 523 | 148 | 185 | 2729 | 151 |
    | 24.105.30.129 - 1 | 529 | 528 | 178 | 212 | 2689 | 181 |
    |________________________________________________|______|______|______|______|______|______|
    WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider
  • Hey jaelove,

    Depending on how far you are from your router I would actually try to connect to the 2.4ghz network to see if that helps. 5ghz may be faster but it has lower range and problems with walls and physical barriers.

    If you do continue to have issues I would try switching to a wired connection to ensure it is not a wireless signal issues.